Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Bug voyants boutons poussoir Hager WKT316
#26
(09/02/2022, 13:34:47)filou59 a écrit :
Citation :le voyant 2 doit rester allumé tant qu'une des lumières de la maison (GA attitrées) sont allumées. Cela me permet de voir si j'en ai oublié une que je ne verrai pas comme le garage ou le grenier.

On ne peux pas faire une synthèse d'etat sur un voyant en fonction de l'etat de plusieurs sortie en KNX.
Enfin on ne peut pas faire ca simplement...
Le KNX est un bus evennementiel, si tu as 2 retour L1 et L2 qui sont sur la meme GA 1/1/1
Si la 1ere lampe s'allume : L1 va envoyer 1 sur 1/1/1
Si le 2eme lampe s'allume : L2 va envoyer 1 sur 1/1/1
Si L1 s'éteint : L1 va envoyer 0 sur 1/1/1 or L2 est encore allumé, c'est pas du temps réel, c'est de l'evennementiel.
Pour pouvoir faire ca , il faut utiliser des fonction logiques : L1 ET (AND) L2 vers une GA 1/1/1 , L3 ET L4 vers GA 1/1/2, 1/1/1 ET 1/1/2 vers 1/1/3 et ca serait 1/1/3 qui contiendrais le resultat de tous les retour d'info.
Pour faire ca il faut soit un participant ayant assez de module logique, parfois on en trouve dans des actionneurs ou autre... ou sinon il faut ajouter un participant faisant que ca , comme le module ABB qui est parfois cité.

Ce qui me laisse perplexe c'est que ça fonctionnait bien avant que j'y mette la supervision Home Assistant. Je suppose que mes actionneurs Hager n'ont pas de module logique ? Si tu as une proposition d'équipement à rajouter pour pouvoir le faire à moindre coût cela m'intéresse car je pourrais m'en servir pour ma problématique de pourcentage d'ouverture de mes volets roulants (qui ne sont pas les mêmes entre Home Assistant, Alexa et ETS). J'ai vu qu'il y en a beaucoup à différents prix chez MDT et ABB...mais je vois pas lequel il me faudrait.
Répondre
#27
J'ai du mal a croire que ca puisse fonctionner, peut être que tu n'avais tout simplement pas provoqué de cas de ce genre ?

Ou alors j'ai zappé un truc, si qq d'autre a une idée ? mais je ne pense pas.

Non pas de module logique dans tes actionneur ou BP.

Je n'ai pas du tout d'experience avec les module logique car moi j'utilise des automate WAGO quand je dois en faire. Mais bon le module logique ABB ABA... a l'air sympa, si je devais en choisir un je prendrais celui-là
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#28
(09/02/2022, 21:23:52)filou59 a écrit : J'ai du mal a croire que ca puisse fonctionner, peut être que tu n'avais tout simplement pas provoqué de cas de ce genre ?

Ou alors j'ai zappé un truc, si qq d'autre a une idée ? mais je ne pense pas.

Non pas de module logique dans tes actionneur ou BP.

Je n'ai pas du tout d'experience avec les module logique car moi j'utilise des automate WAGO quand je dois en faire. Mais bon le module logique ABB ABA... a l'air sympa, si je devais en choisir un je prendrais celui-là
Je n'ai jamais eu un seul loupé en 5 ans alors que depuis que j'ai mis Home Assistant c'est 4-5 fois par semaine et je suis obligé de redémarrer le bus pour revenir à la normale. Cela a peut être un lien de cause à effet?
Je ne connais pas les automates WAGO.
Au final que dois je faire? On essaye les modifications sur ETS que tu as faite? Je me range à ton avis. Je voudrais vraiment trouver un moyen pour faire marcher tout ça
Répondre
#29
(09/02/2022, 14:16:44)Stef42 a écrit :
(09/02/2022, 13:34:47)filou59 a écrit :
Citation :le voyant 2 doit rester allumé tant qu'une des lumières de la maison (GA attitrées) sont allumées. Cela me permet de voir si j'en ai oublié une que je ne verrai pas comme le garage ou le grenier.

On ne peux pas faire une synthèse d'etat sur un voyant en fonction de l'etat de plusieurs sortie en KNX

[...]
Ce qui me laisse perplexe c'est que ça fonctionnait bien avant que j'y mette la supervision Home Assistant

[...]


Juste un commentaire du fonctionnement des voyants avec les WKT31x.

Lorsque j'ai commencé à reprendre mon installation, j'avais 2 BP WKT316 configurés pour faire un ALL OFF sur une AG dédié.
Le voyant était configuré pour rester allumé tant qu'une des lampes était effectivement allumée.
Pour ce faire, le bouton concerné était configuré de façon a allumer le voyant en fonction de l'état de TOUTES les IE (je suis quasi certain qu'il fait un OU logique interne) et l'appuis le sur bouton envoi uniquement un OFF sur l'AG dédiée.

Ce comportement a probablement été programmée avec un TX100.

Je n'ai pas réussi a reproduire ce fonctionnement avec ETS avec le WKT316 car l'application ne fait apparaitre que les Objets de Groupe concernées par le mode choisi. Il faudrait une version de l'application qui fasse apparaitre toute les objets de groupes, qu'ils soient utilisée ou non.

Par ex, pour le WKT312, j'ai une version du logiciel qui permet de faire ce qu'on veut avec les objets de groupes (je ne défini pas le comportement via les paramètres, mais en fonction des objets utilisés).

Voici à quoi ca ressemble pour le WKT312 : 

https://www.knx-fr.com/showthread.php?ti...9#pid54749

@Stef42. Une fois que tu as reprogrammé ton BP avec ETS, il n'est plus possible de faire marche arrière. Dans mon cas, j'ai perdu la fonctionnalité du voyant d'AG sur 1 de mes bouton. Du coup je n'ai pas reprogrammé le deuxième.

La solution serait de trouver une ancienne version de l'application dans un projet KNXPROJ (par un BDD produit KNXPROD) qui ait toute les objets de groupe visible.

J'avais fait une demande en ce sens sur le post cité, mais malheureusement je n'ai pas eu de retours.
Répondre
#30
Je ne connais pas du tout ce qu'il est possible de faire avec du TX100, mais je ne vois pas comment il est possible de faire une synthèse de marche (L1 ou L2 ou LX) sans fonction logique que ce soit avec TX100 ou ETS, il faut passer par des fonctions logique.

Si on a pas de fonction logique on ne met pas de voyant sur le ALL OFF. Il reste a s'assurer que le retour d'etat soient bien paramétré pour que la synchro avec les BP locaux soit effective.
Si fonction logique alors là on peut faire un voyant sur le ALL OFF.

pierrem et Stef42 : Vous avez tout les 2 un point commun il me semble la reprise d'une install Hager faite en TX100 mais qui est aussi équipé d'un Domovea.
Domovea permet de faire de la logique, donc si vous aviez un voyant ALL OFF fonctionnel c'est que la fonction avait été paramétré dedans, c'est tout.

Je connais pas du tout Domovea, il faut une appli Hager Pilot visiblement , vous l'avez deja utilisé ?
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#31
(10/02/2022, 10:52:02)filou59 a écrit : Je ne connais pas du tout ce qu'il est possible de faire avec du TX100, mais je ne vois pas comment il est possible de faire une synthèse de marche (L1 ou L2 ou LX) sans fonction logique que ce soit avec TX100 ou ETS, il faut passer par des fonctions logique.

Si on a pas de fonction logique on ne met pas de voyant sur le ALL OFF. Il reste a s'assurer que le retour d'etat soient bien paramétré pour que la synchro avec les BP locaux soit effective.
Si fonction logique alors là on peut faire un voyant sur le ALL OFF.

pierrem et Stef42 : Vous avez tout les 2 un point commun il me semble la reprise d'une install Hager faite en TX100 mais qui est aussi équipé d'un Domovea.
Domovea permet de faire de la logique, donc si vous aviez un voyant ALL OFF fonctionnel c'est que la fonction avait été paramétré dedans, c'est tout.

Je connais pas du tout Domovea, il faut une appli Hager Pilot visiblement , vous l'avez deja utilisé ?

Pour ma part pas de Domovea justement j'ai préféré passer sur Home Assistant pour pouvoir gérer moi même et avoir une compatibilité avec plus d'appareils. Et cela fonctionnait bien avant donc je soupçonne en effet que cela vient de la programmation sous TXA 100 qui doit intégrer de la logique. Non ?
Répondre
#32
Tu es sur ? Mais pourquoi alors il y a plein de GA qui s'appelle Domovea dans ton projet ? C'est pas toi qui les a appeler comme ca ? Tu as quand meme une petite centaine de GA qui porte le nom de Domovea !!!

C'est impossible la logique est dans les participant, c'est le principe du KNX. La telecommande TX100 c'est un moyen de paramétrage comme ETS.
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#33
(10/02/2022, 11:44:04)filou59 a écrit : Tu es sur ? Mais pourquoi alors il y a plein de GA qui s'appelle Domovea dans ton projet ? C'est pas toi qui les a appeler comme ca ? Tu as quand meme une petite centaine de GA qui porte le nom de Domovea !!!

C'est impossible la logique est dans les participant, c'est le principe du KNX. La telecommande TX100 c'est un moyen de paramétrage comme ETS.

Oui cela devait être fait dans un second temps par mon électricien et j'ai changé d'avis vu le surcoût. Je n'ai pas de module Domovea c'est certain.
Répondre
#34
OK donc il avait préparé le boulot alors car si c'est pas toi qui les a fait (toutes les GA en 2/4 ?)
Donc toutes les GA marqué Domovea pourrait être supprimé pour y voir plus clair ?
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#35
(10/02/2022, 12:50:09)filou59 a écrit : OK donc il avait préparé le boulot alors car si c'est pas toi qui les a fait (toutes les GA en 2/4 ?)
Donc toutes les GA marqué Domovea pourrait être supprimé pour y voir plus clair ?

Non car certaines sont utilisées
Répondre
#36
(10/02/2022, 10:52:02)filou59 a écrit : Je ne connais pas du tout ce qu'il est possible de faire avec du TX100, mais je ne vois pas comment il est possible de faire une synthèse de marche (L1 ou L2 ou LX) sans fonction logique que ce soit avec TX100 ou ETS, il faut passer par des fonctions logique.

[...]

pierrem et Stef42 : Vous avez tout les 2 un point commun il me semble la reprise d'une install Hager faite en TX100 mais qui est aussi équipé d'un Domovea.
Domovea permet de faire de la logique, donc si vous aviez un voyant ALL OFF fonctionnel c'est que la fonction avait été paramétré dedans, c'est tout.

Je connais pas du tout Domovea, il faut une appli Hager Pilot visiblement , vous l'avez deja utilisé ?

J'ai effectivement un Domovea v1, mais il n'est pas du tout utilisé pour faire une fonction logique de synthèse sur les AG de lumière.
Dans mon cas, il sert uniquement de visu générale et d'accès distant.   

DE MEMOIRE, Voici ce que j'ai observé sur le fonctionnement du voyant du BP sur le WKT316.


Configuration : Télérupteur
Utilisation du voyant : indication d'état  

Cela active les objets : 
0: Indication d'état
1: ON/OFF
47: Voyant 1 


J'avais configuré dans : 
- l'objet 0 (IE), toute les AG des IE concernée
- l'objet 1, l'AG utilisée pour l'extinction générale.
- l'objet 47 : non utilisé

Dans ce cas, le voyant reste allumé tant qu'il y a des lampe allumées.
par contre, ca ne fait pas ce qu'on veux, vu que c'est un télérupteur (ca allume ce qui éteint, sans éteindre).
En fait, ca ne fonctionne que si le bouton pouvait envoyer un OFF sur l'AG.

Malheureusement, quand on configure le bouton en ON/OFF, l'objet 0 des IE disparait, et on ne peut pas recréer ce fonctionnement.
Répondre
#37
Du coup personne n'a d'idée sur le comment la programmation est réalisée pour que cela fonctionne sans Domovea et sans module logique ? Je cherche toujours pour un module logique histoire de voir le prix mais y en a tellement que je ne sais pas celui qui conviendrait.
Je me demande si le fait de reprogrammer le bouton poussoir avec le TXA100 remettrait de l'ordre et ferait refonctionner mon installation correctement ?
Répondre
#38
Bonjour Stef42.
Quand j'aurais un peu de temps, je vais essayer de reproduire un bouton ALL STOP avec un WKT312 sur ETS pour voir comment ça réagit.
Ce serait intéressant en effet que tu reprogrammes ton BP avec le TX100 et que tu fasses un "info participant (avec communication de groupe)" pour voir quels objets sont activé.
Tu pourras voir quels objets sont effectivement configurés. Ca m'intéresse aussi ;-) .
Il y a peut être une différence de version de l'application.
Pierre
Répondre
#39
(18/02/2022, 10:52:08)pierrem a écrit : Bonjour Stef42.
Quand j'aurais un peu de temps, je vais essayer de reproduire un bouton ALL STOP avec un WKT312 sur ETS pour voir comment ça réagit.
Ce serait intéressant en effet que tu reprogrammes ton BP avec le TX100 et que tu fasses un "info participant (avec communication de groupe)" pour voir quels objets sont activé.
Tu pourras voir quels objets sont effectivement configurés. Ca m'intéresse aussi ;-) .
Il y a peut être une différence de version de l'application.
Pierre

Le souci c'est que je n'ai pas ce TXA100...
Répondre
#40
Je commence à vraiment me poser des questions sur ce que je dois faire. En utilisant d'autres lumières je finis par avoir la lumière du salon et du séjour qui sont soit disant allumées dans HA alors que ce n'est pas le cas. Des fois il y a aussi les escaliers qui sont sur timer pourtant...L'indication du retour d'état n'est donc pas bon je suppose. La question c'est pourquoi? Car cela ne se limite pas au voyant de mes boutons...qu'est ce qui se passe à votre avis pour que cela se comporte comme si l'AG pour l'allumage/extinction avait été utilisé ?

[Image: 1646599843-screenshot-20220303-114418-ho...istant.jpg]
Répondre
#41
Salut
Des incohérence dans la programmation il y en a pas mal d'après ce que j'ai pu voir.

Moi ce qui me gene c'est quand tu me dis que ca a fonctionné ? Moi je ne voie pas comment cela a pu fonctionner ?

Supposition 1 : La programmation a la pocket TX100 permet ce genre de chose ... ok pourquoi pas mais l'applicatif, les param ou les possibilités que l'on utilise ETS ou sous un TX100 ce sont les même !!! Ou alors j'ai zappé un truc.

Supposition 2 : Ca na jamais fonctionné ,mais tu n'as jamais constaté le problème ? ou cette synthèse n'existait pas.

Le problème c'est la synthèse d'état de plusieurs lampe : il n'y a pas de magie : Lampe 1 ou Lampe 2 ou Lampe X c'est une équation Logique (Binaire ou Booleene) cela nécessite des fonctions logiques.

Je ne voie ou ne connais aucune solution pour le faire autrement.


Soit tu t'assoies sur cette fonction et tu n'utilise de Synthèse de retour d'etat.
Soit tu l'implementes via l'achat d'un module Logique type ABB
Soit tu l'implementes dans un superviseur via une équation logique HA/Nodered... (Cette solutions étant la moins recommandé quand on veut du pur KNX)
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#42
(11/03/2022, 09:50:36)filou59 a écrit : Salut
Des incohérence dans la programmation il y en a pas mal d'après ce que j'ai pu voir.

Moi ce qui me gene c'est quand tu me dis que ca a fonctionné ? Moi je ne voie pas comment cela a pu fonctionner ?

Supposition 1 : La programmation a la pocket TX100 permet ce genre de chose ... ok pourquoi pas mais l'applicatif, les param ou les possibilités que l'on utilise ETS ou sous un TX100 ce sont les même !!! Ou alors j'ai zappé un truc.

Supposition 2 : Ca na jamais fonctionné ,mais tu n'as jamais constaté le problème ? ou cette synthèse n'existait pas.

Le problème c'est la synthèse d'état de plusieurs lampe : il n'y a pas de magie : Lampe 1 ou Lampe 2 ou Lampe X c'est une équation Logique (Binaire ou Booleene) cela nécessite des fonctions logiques.

Je ne voie ou ne connais aucune solution pour le faire autrement.


Soit tu t'assoies sur cette fonction et tu n'utilise de Synthèse de retour d'etat.
Soit tu l'implementes via l'achat d'un module Logique type ABB
Soit tu l'implementes dans un superviseur via une équation logique HA/Nodered... (Cette solutions étant la moins recommandé quand on veut du pur KNX)

C'est aussi ce que je ne comprends pas mais cela fonctionnait très bien sans HA. Les voyants de mes touches ont toujours fonctionné au poil.
La question que je pose c'est est ce qu'en reprenant la programmation à 0 sous ETS le fonctionnement des voyants sera correct ? Par ex pour la touche "Extinction des lumières" est ce que je peux "dire" tant qu'il y a une lumière allumée le voyant reste allumé ? Si oui comment ? On me parlait de créer une AG pour toutes les lumières et la mettre à la place de toutes celles mises sur le voyant mais est ce que cela va marcher comme je le veux ?
Répondre
#43
Je sais pas comment te le dire, je ne peux pas etre plus clair.

Non je ne sais pas faire sans equation logique (donc sans module ou fonction logique), je ne voie pas comment tu pourrais faire sans passage par un module ABB ABA ou autre du meme style. Pour moi c'est impossible.


Citation :Les voyants de mes touches ont toujours fonctionné au poil.

Si tu as des voyants qui correspondent pointent uniquement vers une lampe alors là oui ca se corrige facilement. 
Sinon voir mes X réponses....
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#44
(15/03/2022, 10:02:47)filou59 a écrit : Je sais pas comment te le dire, je ne peux pas etre plus clair.

Non je ne sais pas faire sans equation logique (donc sans module ou fonction logique), je ne voie pas comment tu pourrais faire sans passage par un module ABB ABA ou autre du meme style. Pour moi c'est impossible.


Citation :Les voyants de mes touches ont toujours fonctionné au poil.

Si tu as des voyants qui correspondent pointent uniquement vers une lampe alors là oui ca se corrige facilement. 
Sinon voir mes X réponses....

Ok donc impossible de le faire via ETS mais à priori via TXA100 oui du coup.

Par contre au delà des voyants, les retours d'état ne semblent pas être corrects non plus puisque cela me dit que certaines lampes sont allumées alors que l'on n'a pas touché aux boutons (et donc les AG en ON/OFF) les concernant (voir dernier screenshot de HA). Comment expliquer cela ?
Répondre
#45
Citation :Ok donc impossible de le faire via ETS mais à priori via TXA100 oui du coup.
Je ne connais pas le TX100 mais je suis très perplexe, l'application se trouve dans le participant que ce soit un TX100 ou ETS on a la meme application...



Citation :Par contre au delà des voyants, les retours d'état ne semblent pas être corrects non plus puisque cela me dit que certaines lampes sont allumées alors que l'on n'a pas touché aux boutons (et donc les AG en ON/OFF) les concernant (voir dernier screenshot de HA). Comment expliquer cela ?

Estce que tu peux etre plus précis ?
Tes voyants associé a des BP de lampe pointe vers un retour d'etat.
Tu peux donner un exemple ? 
Car moi sur ton screen je peux pas deviner si la lumiere du Séjour est réellement allumé ou non.
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#46
(16/03/2022, 10:21:20)filou59 a écrit :
Citation :Ok donc impossible de le faire via ETS mais à priori via TXA100 oui du coup.
Je ne connais pas le TX100 mais je suis très perplexe, l'application se trouve dans le participant que ce soit un TX100 ou ETS on a la meme application...



Citation :Par contre au delà des voyants, les retours d'état ne semblent pas être corrects non plus puisque cela me dit que certaines lampes sont allumées alors que l'on n'a pas touché aux boutons (et donc les AG en ON/OFF) les concernant (voir dernier screenshot de HA). Comment expliquer cela ?

Estce que tu peux etre plus précis ?
Tes voyants associé a des BP de lampe pointe vers un retour d'etat.
Tu peux donner un exemple ? 
Car moi sur ton screen je peux pas deviner si la lumiere du Séjour est réellement allumé ou non.

Je vais voir pour trouver l'info sur comment fonctionne le TXA100 mais pour sûr cela a fonctionné 5 ans donc je n'ai aucun doute là dessus.

Pour ex, dans HA je m'aperçois souvent qu'il y a la lumière du séjour, du salon et/ou des escaliers qui sont soit disant allumées mais en fait elles ne le sont pas. Cela ne le fait que sur ces 3 lumières. Donc de ce fait, les voyants sur les touches de mes BP sont aussi allumés alors que réélement les lumières sont éteintes. Pour pallier au problème je suis obligé d'éteindre soit via HA soit le BP puis de rallumer et enfin éteindre de nouveau pour que l'état redevienne correct dans HA et sur les voyants de mes touches. Je soupçonne donc quelque chose activer l'AG de chaque lumière (salon séjour et escaliers) et envoyer un mauvais retour d'état à HA et aux touches sur mes BP.
C'est dans ce sens que j'aimerais déjà qu'on m'aiguille sur ce qui peut provoquer cela. Car au final ce sont les retours d'état (visibles dans HA) qui font que cela fausse l'allumage des voyants car cela suit bien le retour d'état que j'ai dans HA. On peut peut être regarder dans ETS où sont utilisées les AG en ON/OFF pour ces 3 lumières ?
Répondre
#47
Tu devrais regarder le sujet sur les flags
Es-tu sûr que c’est l’actionneur qui renvoie son état et non le bouton??
Répondre
#48
(16/03/2022, 13:40:16)richardpub a écrit : Tu devrais regarder le sujet sur les flags
Es-tu sûr que c’est l’actionneur qui renvoie son état et non le bouton??

Je ne sais pas j'ai besoin d'aide pour cela. Je remets les infos :

Le modèle de bouton poussoir Hager WKT316 :

[Image: 1643311505-20220127-194250.jpg]

Le paramétrage de mon bouton poussoir dans ETS :

[Image: 1643311851-etsvoyants.png]

Le paramétrage de l'actionneur :
Ex de l'output 1 qui concerne les escaliers

[Image: 1643446354-etsvoyants3.png]

Mon projet est sous ETS 6 si quelqu'un peut regarder directement ou le faire avec moi via teamviewer ou anydesk

Je suis un peu perdu avec tout ça et j'aimerai vraiment trouver d'où vient le problème....prochain coup où cela arrive je regarde sur l'actionneur si il est allumé ou non (pour savoir si c'est bien l'actionneur qui envoie l'info ?)

EDIT : dans HA j'ai le salon et séjour qui sont sensés être allumés mais quand je regarde sur l'actionneur ils ne sont pas allumés...cela vient des boutons alors? Je comprends pas. De plus en vérifiant l'actionneur et en revenant dans HA les escaliers paraissent allumés alors que ce n'est pas le cas...et je n'ai pas touché aux BP qui concernent ces lumières!

Merci pour votre aide
Répondre
#49
Montres nous les GA concernés et les paramètres associés
Répondre
#50
(16/03/2022, 23:22:40)richardpub a écrit : Montres nous les GA concernés et les paramètres associés

Je ne sais pas si c'est cette vue que tu veux :
* Escaliers :
AG On/Off :
[Image: 1647501810-ag-onoff-escaliers.png]

AG IE :
[Image: 1647501810-ag-ie-escaliers.png]


* Salon :
AG On/Off :
[Image: 1647501810-ag-onoff-salon.png]

AG IE :
[Image: 1647501810-ag-ie-salon.png]


* Sejour :
AG On/Off :
[Image: 1647501810-ag-onoff-sejour.png]

AG IE :
[Image: 1647501810-ag-ie-sejour.png]
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)